honnjitsuhaseitennnari
onemunemunemu

このサイトに書かれていることが原因でトラブルを発生したとしても、私は一切の責任を負いません。ご了承の上、閲覧下さいますようよろしくお願い致します。
なおこのサイトはリンクフリーです。

Linus Torvalds 様、ならびに世界中においてボランティアで Linux の開発に携わっている皆々様方に敬意を表しますとともに心から感謝いたします。

Red Hat 9 Server デスクトップ実物大 (要クリック)
freshmeat (/usr/share/backgrounds/images)
Vine Linux Firefox Java Plugin
Vine Linux 3.2 Client / pooh
以下の説明を見ると Firefox で Java を使うためにはプラグインのシンボリックを張ればよいことがわかります。


Firefox FAQ よりの引用:
Linux では、JRE 1.4.2 以降のバージョンが必要です。

Firefox は gcc 3.2.3 でコンパイルされており、互換性のある Java プラグインを使う必要があります。JRE 1.4.2 には互換性のあるプラグインが含まれています。

JRE 1.4.2_05 RPM をインストールした場合、このプラグインは /usr/java/j2re1.4.2_05/plugin/i386/ns610-gcc32/
libjavaplugin_oji.so になります。
Firefox にインストールするには次の手順に従ってください。

* ターミナルを開きます。
* Firefox のプラグインディレクトリに移動します。
* 次のコマンドを実行してください: ln -s /usr/java/j2re1.4.2_01/plugin/i386/ns610-gcc32/
libjavaplugin_oji.so

古い Linux ディストリビューションをお使いの場合は、gcc3 サポートライブラリをインストールする必要があります。gcc 3.2 でコンパイルされている Java プラグインは、実行に libgcc_s.so.1 が必要となるためです。Google でパッケージを探してください。

Firefox の古いバージョンまたは非公式ビルドをお使いの場合は、ロケーションバーに about:buildconfig と入力して Enter キーを押し、どのコンパイラが使われているか確認してください。
"gcc version 3.3 20030226 (prerelease) (SuSE Linux)" といった行があったら、それが使われたコンパイラを示しています。
gcc 2.9x が使われていた場合は、ns610-gcc32 プラグインではなく ns610 プラグインを使ってください。


# cd /usr/lib/firefox-1.5/plugins


# ln -s /usr/java/jre1.5.0_07/plugin/i386/ns7/libjavaplugin_oji.so


# ls
libjavaplugin_oji.so@ libnullplugin.so libunixprintplugin.so


firefox 再起動。
アドレス入力欄に about:plugins とタイプ。


あれ〜。java プラグインが認識されていない!
因みに firefox1.5.0.4 。
gcc : 3.3


画像をクリックすると拡大画面が開きます


Java ソフトウェアのインストール状況の確認
で調べてみると

申し訳ありません。
Java Runtime Enviornment (JRE) を一定時間内に検出できませんでした。
ブラウザで最新の JRE または互換性のある JRE が使用されていない可能性があります。



Vine Linux Eclipse Install を見て頂くと解りますが普通に java 使えています。
| comments(0) | trackbacks(0) | - | - |
pagetop
<< Vine Linux Java Install | main | Vine Linux Mesa Install >>









url: トラックバック機能は終了しました。

08
--
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
--
>>
<<
--